线段树+dfs HDU - 3974

Assign the task

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2660    Accepted Submission(s): 1120


Problem Description
There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.
 

Input
The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)
 

Output
For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.
 

Sample Input
  
  
1 5 4 3 3 2 1 3 5 2 5 C 3 T 2 1 C 3 T 3 2 C 3
 

Sample Output
  
  
Case #1: -1 1 2
 
题意:一个公司里的人员安排就是一棵树,有父节点的是下属,有子节点的是老板,老板的下属的所有下属也是这个老板的下属,首先给出u, v表示v是u的老板,关系给出后,有两种操作,C   x表示查询x号员工及其 下属正在做的工作,T   x  y表示给x号员工及其下属安排工作y。
解题:因为需要联系各个节点的所有子节点,用dfs对在一棵树上的节点重新编号。代码需要好好理解。
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
#include <map>
#include <set>

using namespace std;
int task[50010<<2], col[50010<<2], pos;
vector<int> vec[50010];
int id[50010], len[50010], cnt, vist[50010];

void Build()
{
//    memset(task, -1, sizeof(task));
    memset(col, -1, sizeof(col));
}

void pushdown(int rt)
{
    if(col[rt] != -1) {
//        task[rt<<1] = task[rt<<1|1] = col[rt];
        col[rt<<1] = col[rt<<1|1] = col[rt];
        col[rt] = -1;
    }
}

void update(int L, int R, int l, int r, int rt, int c)
{
    if(L<=l && r<=R) {
        col[rt] = c;
//        task[rt] = c;
        return ;
    }
    pushdown(rt);
    int mid = (l+r)>>1;
    if(L <= mid) update(L, R, l, mid, rt<<1, c);
    if(mid < R) update(L, R, mid+1, r, rt<<1|1, c);
}

int query(int l, int r, int m, int rt)
{
    if(l == r) return col[rt];
    pushdown(rt);
    int mid = (l+r)>>1;
    if(m <= mid) return query(l, mid, m, rt<<1);
    else return query(mid+1, r, m, rt<<1|1);
}

int dfs(int u) // 用dfs给同一棵树上的节点编号
{
    id[u] = cnt;
    cnt++;
    len[u] = 0;
    for(int i = 0; i < vec[u].size(); i++)
        len[u] += dfs(vec[u][i]);
    return len[u]+1;
}

int main()
{
    int T, casee = 1;
    scanf("%d", &T);
    while(T--) {
        cnt = 1;
        int n;
        scanf("%d", &n);
        for(int i = 1; i <= n; i++) vec[i].clear();
        memset(vist, 0, sizeof(vist));
        for(int i = 1; i < n; i++) {
            int u, v;
            scanf("%d%d", &u, &v);
            vec[v].push_back(u);
            vist[u] = 1;
        }
//        printf("vist[1] = %d\n", vist[1]);
        for(int i = 1; i <= n; i++) {
            if(!vist[i]) dfs(i);
        }
//        printf("id[2] = %d, len[1] = %d\n", id[2], len[1]);
        Build();
        int m;
        scanf("%d", &m);
        printf("Case #%d:\n", casee++);
        while(m--) {
            char op[5];
            scanf("%s", &op);
            if(op[0] == 'T') {
                int x, y;
                scanf("%d%d", &x, &y);
//                printf("%d %d\n", id[x], len[x]);
                update(id[x], id[x]+len[x], 1, n, 1, y);
            }
            else {
                int x;
                scanf("%d", &x);
                printf("%d\n", query(1, n, id[x], 1));
            }
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值