poj 2406 Power Strings(未优化的KMP)

poj 2406 Power Strings(未优化的KMP)
Time Limit: 3000ms Memory Limit: 65536kB

Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output
For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source
Waterloo local 2002.07.01


这个题本身很简单,是用来复习未优化的KMP的。
题意很清晰,想法就是计算KMP中的next[]数组,因为next[]不同规定导致下标不同,所以统一以教材版本为准:
next[i]=max k:a[0,k1]==a[ik,i1](i>0)    or  1(i==0)
这是不优化版本的,代码实现见下calculate_next();优化版本见课本,注意求解calculate_next()本身用了KMP算法。


Accepted    12800kB 51ms    534 B   G++
#define LEN 1000000

#include<stdio.h>
#include<string.h>

char s[LEN+1];
int next[LEN+1];
int len;

void calculate_next()
{
    int k;
    next[0]=-1;
    for (int i=1;i<=len;i++)
    {
        k=next[i-1];
        while (s[k]!=s[i-1] && k>=0)
            k=next[k];
        if (s[k]==s[i-1])
            next[i]=k+1;
        else
            next[i]=0;
    }
    return;
}

int main()
{
    while (scanf("%s\n",&s)==1)
    {
        len=strlen(s);
        if (len==1 && s[0]=='.')
            break;
        calculate_next();
        if (len%(len-next[len])==0)
            printf("%d\n",len/(len-next[len]));
        else
            printf("1\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值