HDU 3336-Count the string(kmp+DP)

Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

 

 

Input

The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

 

 

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

 

 

Sample Input

 

1

4

abab

 

 

Sample Output

 

6

题目大意:给出一个串求它所有前缀的出现次数和。

思路:因为kmp中的next数组记录的是相同前后缀部分,而我们找的是前缀出现的次数,所以自我匹配时若next非0即有相同前后缀---即有前缀重复出现,但这时重复出现是以前缀子串为单位的,所以在统计次数时需要对该子串以及它包含的前缀子串叠加。

就有转移方程 dp[i]=dp[next[k]]+1 总个数为(n+\sumdp[i])%10007.

因为这个题的数据很弱,用递推或是某些错误做法也能过.........

代码如下:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<string>
#include<math.h>
#include<queue>
#include<stack>
#define per(i,a,b) for(int i=a;i<=b;++i)
#define rep(i,a,b) for(inr i=a;i>=b;--i)
#define inf 0xf3f3f3f
#define ll long long int
using namespace std;
char s[1000005];
int p[1000005],p1[1000005],n,z;
void fun()
{
	p[0]=-1;
	int k=-1,j=0;
	while(j<n)
	{
		if(k==-1||s[j]==s[k]) 
		{
		    if(k!=-1) p1[j]=p1[k]+1,z+=p1[j];
			++k,++j,p[j]=k; 
		}
		else k=p[k];
	}
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		z=0;
		memset(p,0,sizeof(p));
		memset(p1,0,sizeof(p1));
		scanf("%d",&n);
		cin>>s;
		fun();
		cout<<(z+n)%10007<<endl; 
	} 
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值