POJ1363 Rails(数据结构小实验)

题目四:Rails(***)

[Description]

···There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

···The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, …, N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, …, aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

[Input]

···The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, …, N. The last line of the block contains just 0.

···The last block consists of just one line containing 0.

[Output]

···The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null’’ block of the input.

[Sample Input]

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

[Sample Output]

Yes
No
Yes

代码部分:

#include<bits/stdc++.h>
using namespace std;
struct Node{
	int a;
	Node* next;
};
Node* CreateStack(){
	Node* top=(Node*)malloc(sizeof(Node));
	top->next=NULL;
	return top;
}
void push(Node* head,int k){
	Node* p=(Node*)malloc(sizeof(Node));
	p->a=k;
	p->next=head->next;
	head->next=p;
}
int top(Node* head){
	return head->next->a;
}
void pop(Node* head){
	int temp=head->next->a;
	Node* p=head->next;
	head->next=head->next->next;
	free(p);
}
bool isempty(Node* head){
	if(head->next==NULL) return true;
	return false;
}
void dispaly(Node* head){
	Node* p=head;
	while(p->next!=NULL){
		p=p->next;
		printf("%d ",p->a);
	}puts("");
}
int main()
{
	
	int n,seq[200];	
	while(~scanf("%d",&n))
	{
		Node* Stack=CreateStack();
	loop:	for(int i=1;i<=n;i++)	scanf("%d",&seq[i]);
		if(!seq[1]) return 0;
		push(Stack,seq[n]);
		int k=n-1,t=n;
		bool boo=0;
		while(!isempty(Stack)){
			bool flag=0;
			if(top(Stack)==t){
				pop(Stack);
				t--;
				flag=1;
			}
			if(k==0&&flag==0){
				boo=1;
				puts("No");
				break;
			} 
			if(k>0) push(Stack,seq[k--]);	
		}
		if(!boo) puts("Yes");
		int temp=0;
		scanf("%d",&temp);	
		if(temp!=0) goto loop;
	}
}

思路:

简单来说就是出栈顺序可能性的评判,那么有两种思路,递归每个入栈元素的IO(入栈出栈)两种判定后与所给数据进行对比,但是O(2n)的复杂度太高难以接受。于是考虑到栈FILO的特性,进行还原模拟即可,将当前序列中最后出栈的元素入栈,之后将栈顶元素与原来序列中最后出栈的元素进行对比,若相同则出栈栈顶元素,若不同则入栈当前序列中最后出栈的元素。若当前序列已空,但却无法出栈,则说明此顺序不可能出现。(其实就是贪心而已)。
P.S. dispaly函数是为了方便查看栈中顺序。如果不是非要手写栈,用STL或者数组我30行都用不了,数据结构课程设计好麻烦啊啊啊啊啊~~~~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值