pku1001题解

Exponentiation
Time Limit:500MS  Memory Limit:10000K
Total Submit:22256 Accepted:5036

Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

 548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

  这道题目很繁琐,考虑的方面也很多,不过很锻炼编码和改错的能力
题目的解法就是一个高精度问题,用数组模拟乘法运算,这道题目值得收藏
以下是代码

#include  < iostream >
using   namespace  std;

const   int  MAX  =   1000 ;

int  length( int  num)
{
  
int k = 0;
  
while(num/10 != 0)
  
{
    k
++;
    num 
/= 10;
  }

  
return k+1;
  
}



void  Multiply( int  result[],  int &  resultlen,  int  digit[],  int  k)
{
  
int i;
  
int j;
  
int len;
  
int re[MAX];
  
for (i = 0; i < MAX; i++)
    re[i] 
= 0;
  
  
for (i = 0; i < k; i++)
    
for (j = 0; j < resultlen; j++)
    
{
        re[i
+j] += result[j] * digit[i];
        re[i
+j+1+= re[i+j] / 10;
        re[i
+j] %= 10;
    }

  len 
= resultlen + k;
  
if (re[len-1== 0)
    len
--;
  resultlen 
= len;
  
for (i = 0; i < len; i++)
    result[i] 
= re[i];
}
 

int  main()
{
  
double r;
  
int n;
  
int dot;
  
int i;
  
int j;
  
int k;
  
int m;
  
int digit[MAX];
  
int result[MAX];
  
int resultlen;
  
bool flag = true;
  
  
while (cin >> r >> n)
  
{
    i 
= length((int)r);
    
if (i == 1)
    
{
        dot 
= 4;
        r 
= r * 10000;
    }

    
else
    
{
        dot 
= 3;
        r 
= r * 1000;
    }

    
long int number = (long int)r;
    
    dot 
= dot * n;
    
if (number == 0
    
{
          cout 
<< "0" <<endl;
          
continue;
    }

    
    
for (i = 0; i < MAX; i++)
    
{
        digit[i] 
= 0;
        result[i] 
= 0;
    }

    
    k 
= length(number);
    
    resultlen 
= k;
    
    
    
for (i = 0; i < k; i++)
    
{
        digit[i] 
= result[i] = number % 10;
        number 
/= 10;   
    }

  
    
for (i = 0; i < n-1; i++)
        Multiply(result, resultlen, digit, k);
        
    
    i 
= 0;
    
while (i < dot)
    
{
        
if (result[i] != 0)
          
break;
        i
++;
    }

        
    
if (i == dot)
        flag 
= false;
    
else
    
{
        flag 
= true;
        m 
= i;
    }

    
    
    
if (resultlen > dot)
    
{
        
for (i = resultlen - 1; i >= dot; i--)
          cout 
<< result[i];
        
if (flag)
        
{
          cout 
<< "." ;
          
for (i = dot - 1; i >= m; i--)
            cout 
<< result[i];
        }
     
    }
   
    
else
    
{
        
if (flag)
        
{
          cout 
<< "." ;
          
for (i = dot - 1; i >= m; i--)
            cout 
<< result[i];
        }

          
    }

        cout 
<< endl;     
  }

  
return 0;
}


 

 

 

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值