RobotFrameWork-ride安装及出错的解决

1. 安装,默认安装当前稳定版本,
pip install robotframework
2.安装可视化工具(目前报错未解决)
pip install robotframework-ride
3.查看安装版本
pip list
pip install robotframework-requests
pip install robotframework-seleniumlibrary

我安装的robotframework是5.0的,在安装ride可视化时候一直报错
检查了一下python环境是3.9最新的,尝试改成3.7安装ride成功

如果还是安装报错,可以改下pip的镜像或者使用yum install之类的
给大家推荐个虚环境Anaconda
Anaconda官网
运行ride
打开Anaconda,使用python37(3.7版本)执行
python D:\software\Anaconda\Anaconda\envs\python37\Scripts\ride.py
在这里插入图片描述

如果遇到输出乱码,将D:\software\Anaconda\Anaconda\envs\python37\Lib\site-packages\robotide\contrib\testrunner\testrunnerplugin.py
500来行的SYSTEM为改OUTPUT

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:深蓝海洋 设计师:CSDN官方博客 返回首页
评论

打赏作者

popoppor

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值