HDU 1905 Pseudoprime numbers【素数】【快速幂】

题目来戳呀

Problem Description

Fermat’s theorem states that for any prime number p and for any integer a > 1, a^p == a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)
Given 2 < p ≤ 1,000,000,000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing “0 0”. Each test case consists of a line containing p and a.

Output

For each test case, output “yes” if p is a base-a pseudoprime; otherwise output “no”.

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes
想法:
先判断素数,再套个快速幂模板。很伤心连模板都不会敲QAQ

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long ll;
ll quickpow(ll a,ll b,ll c)//a的b次方对c取余
{
    ll ans=1;
    a=a%c;
    while(b)
    {
        if(b%2==1)
            ans=ans*a%c;
        b>>=1;//  b=b/2;
        a=a*a%c;
    }
    return ans;

}
int main()
{
    int flag;
    ll a,p;
    while(~scanf("%lld%lld",&p,&a)&&(a||p))
    {
        flag=0;
        for(int i=2;i*i<p;++i)
        {
            if(p%i==0)
            {
                flag=1;
                break;
            }

        }
        if(!flag)
            cout<<"no"<<endl;
        else
        {
            ll tem=quickpow(a,p,p);
            if(tem==a)
                cout<<"yes"<<endl;
            else cout<<"no"<<endl;
        }
    }
    return 0;
}




















  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值