POJ 1703 Find them, Catch them【并查集】

8 篇文章 0 订阅

题目来戳呀

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

  1. D [a] [b]
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

  2. A [a] [b]
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.
    Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message “A [a] [b]” in each case, your program should give the judgment based on the information got before. The answers might be one of “In the same gang.”, “In different gangs.” and “Not sure yet.”

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.
题意:
城市有两个犯罪团伙,一共有n名罪犯,但不知道属于哪一个==告诉我们D代表两个人一定不是一个团伙,A的话不一定,有三种情况。
比如样例,
D 1 2
A 1 2
D 2 4
A 1 4
第一个D说1,2不是一个,那第一个A的1,2就不是一个;第二个D说2,4不是一个,那第二个得1和4就是同一个了,因为都不和2是一个。
想法:
首先要理解题意(没错!)
然后就是并查集的使用了。这个题和poj1182食物链思路一样,但是先做的这个题,在某猪的+n上卡了好久○| ̄|_后来看懂了那题再做这个就很简单~(≧▽≦)/~啦啦啦

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn=100010;
using namespace std;
int f[maxn*2];
int m,n;
void init(int v)
{
    for(int i=0;i<v;++i)
        f[i]=i;
}
int find(int x)
{
    if(f[x]!=x)
        f[x]=find(f[x]);
    return f[x];
}
void join(int u,int v)
{
    int d1=find(u);
    int d2=find(v);
    if(d1!=d2)
    {
        f[d1]=d2;
    }

}
int same(int u,int v)
{
    if(find(u)==find(v))return 1;
    if(find(u)==find(v+n))return 0;
    return 2;
}
int main()
{
    int t;
    int x, y;
    char ch;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        init(n*2);
        while(m--)
        {
            getchar();
            scanf("%c %d %d",&ch,&x,&y);
            if(ch == 'A')
            {
                if(same(x, y) == 0)  cout << "In different gangs." << endl;
                if(same(x, y) == 1)  cout << "In the same gang." << endl;
                if(same(x, y) == 2)  cout << "Not sure yet." << endl;
            }
            else if(ch == 'D')
            {
                join(x, y+n);
                join(x+n, y);
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值