HDU 6063 RXD and math【快速幂】【打表找规律】

题目来戳呀

Problem Description

RXD is a good mathematician.
One day he wants to calculate:
这里写图片描述

output the answer module 10^9+7.
1≤n,k≤10^18
μ(n)=1(n=1)

μ(n)=(−1)k(n=p1p2…pk)

μ(n)=0(otherwise)

p1,p2,p3…pk are different prime numbers

Input

There are several test cases, please keep reading until EOF.
There are exact 10000 cases.
For each test case, there are 2 numbers n,k.

Output

For each test case, output “Case #x: y”, which means the test case number and the answer.

Sample Input

10 10

Sample Output

Case #1: 999999937

Source

2017 Multi-University Training Contest - Team 3

题意:

求公式的值,μ(x)就是莫比乌斯函数。

想法:

先打表,求出1-10的n,1-5的k对应的结果:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int mod=1e9+7;
ll quickmod(ll a,ll b)
{
    ll ans=1;
    a%=mod;
    while(b>0)
    {
        if(b&1)
        {
            ans=(ans*a)%mod;
        }
        b/=2;
        a=(a*a)%mod;
    }
    return ans;
}
int main()
{
    ll n,k;
    int cas=1;
    while(~scanf("%lld%lld",&n,&k))
    {
        printf("Case #%d: %lld\n",cas++,quickmod(n,k));
    }
}

结果为:
这里写图片描述
我们发现结果就是 nk ,所以就愉快的套快速幂的模板辣~

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int mod=1e9+7;
ll quickmod(ll a,ll b)
{
    ll ans=1;
    a%=mod;
    while(b>0)
    {
        if(b&1)
        {
            ans=(ans*a)%mod;
        }
        b/=2;
        a=(a*a)%mod;
    }
    return ans;
}
int main()
{
    ll n,k;
    int cas=1;
    while(~scanf("%lld%lld",&n,&k))
    {///cnt要定义在外面zz

        printf("Case #%d: %lld\n",cas++,quickmod(n,k));
    }
}

ps:打表get√

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值