N!解题报告

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30093    Accepted Submission(s): 8264


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 6
 

Author
JGShining(极光炫影)
 



#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
const int maxn = 50000;
int f[maxn];
int main()
{
	int i,j,n;
	while(cin>>n)
	{
		memset(f,0,sizeof(f));
		f[0]=1;
	
		{
			for(i=2;i<=n;i++)
		{
			int c=0;
			for(j=0;j<maxn;j++)
			{
				int s=f[j]*i+c;
				f[j]=s%10;
				c=s/10;
			}
		}
		for(j=maxn-1;j>=0;j--)
		{
			if(f[j])
				break;
		}
		for(i=j;i>=0;i--)
		{
			cout<<f[i];
		}
		cout<<endl;
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值