J - Transmitters解题报告

J - Transmitters
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

In a wireless network with multiple transmitters sending on the same frequencies, it is often a requirement that signals don't overlap, or at least that they don't conflict. One way of accomplishing this is to restrict a transmitter's coverage area. This problem uses a shielded transmitter that only broadcasts in a semicircle. 

A transmitter T is located somewhere on a 1,000 square meter grid. It broadcasts in a semicircular area of radius r. The transmitter may be rotated any amount, but not moved. Given N points anywhere on the grid, compute the maximum number of points that can be simultaneously reached by the transmitter's signal. Figure 1 shows the same data points with two different transmitter rotations. 

All input coordinates are integers (0-1000). The radius is a positive real number greater than 0. Points on the boundary of a semicircle are considered within that semicircle. There are 1-150 unique points to examine per transmitter. No points are at the same location as the transmitter. 

Input

Input consists of information for one or more independent transmitter problems. Each problem begins with one line containing the (x,y) coordinates of the transmitter followed by the broadcast radius, r. The next line contains the number of points N on the grid, followed by N sets of (x,y) coordinates, one set per line. The end of the input is signalled by a line with a negative radius; the (x,y) values will be present but indeterminate. Figures 1 and 2 represent the data in the first two example data sets below, though they are on different scales. Figures 1a and 2 show transmitter rotations that result in maximal coverage.

Output

For each transmitter, the output contains a single line with the maximum number of points that can be contained in some semicircle.

Sample Input

25 25 3.5
7
25 28
23 27
27 27
24 23
26 23
24 29
26 29
350 200 2.0
5
350 202
350 199
350 198
348 200
352 200
995 995 10.0
4
1000 1000
999 998
990 992
1000 999
100 100 -2.5

Sample Output

3
4
4

这个题目如果完全理解了的话还是不难的。

题目的意思就是给出一个点p和一个半径r,还有n个分散的点,要求的就是由p和r组成的半圆能包含的最多点的个数,这是一个几何题目,首先我们把p和r组成的圆所能包含的点全部找出来,然后保存,圆不能包含的点半圆自然是不能包含的,然后进行一个一个点的枚举。就是说取一个点与p点组成一个向量,作为标志向量,然后再取其余的点与p点组成另外的一个向量,然后将这个新的向量与标志向量做叉积,如果叉积是大于等于零的,那么毫无疑问的说这个点在这个半圆内,然后用max记录最多的点,就这样的了,下面是代码:




#include<iostream>
using namespace std;
struct point 
{
	int x,y;
};
int j,x,y;
point allpoint[150]; //一个圆形的发射器所能覆盖的所有的点的集合
int count(int i)
{
	int k,n=1;
	point temp;//一个标志向量
	temp.x=allpoint[i].x-x;
	temp.y=allpoint[i].y-y;
	for(k=0;k<j;k++)
	{
		if(k==i)
			continue;
		if(temp.x*(allpoint[k].y-y)-(allpoint[k].x-x)*temp.y>=0)//做叉积
			n++;//如果满足 自加
	}
	return n;//返回点的个数
}
int main()
{
	int x1,y1,n,i,max,c;
	double r;
	while(1)
	{
		cin>>x>>y>>r;
		if(r<0)
			break;
		cin>>n;
		for(i=0,j=0;i<n;i++)
		{
			cin>>x1>>y1;
			if((x1-x)*(x1-x)+(y1-y)*(y1-y)<=r*r)//判断点是不是在园内
			{
				allpoint[j].x=x1;//是,则存起来
				allpoint[j].y=y1;
				j++;
			}
		}
		max=0;
		for(i=0;i<j;i++)
		{
			c=count(i);
			if(c>max)
				max=c;
		}
		cout<<max<<endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值