A1002. A+B for Polynomials (25)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2   

题目大意:输入多项式A和B 求和,输入格式   K N1 aN1 N2 aN2 ... NK aNK  K为该多项式项数、N1、aN1分别为该项幂次和系数。

思路: 

构建以数列p[n],用以存储幂次和系数,n为多项式的幂次,p[n]为该项的系数, 数组类型定义为double;

代码如下:

#include <cstdio>

int main()
{
	int K, n, count = 0;
	double an;
	double p[1005] = {};
	
	scanf ("%d", &K);

	for (int i = 0; i < K; i++)
	{
		scanf ("%d%lf", &n, &an);
		p[n] += an;     // 下标存储幂次,该下标表示的元素存储系数;  用+=确保同样幂次的数据不会被覆盖;
	}
	
	scanf ("%d", &K);
	for (int i = 0; i < K; i++)
	{
		scanf ("%d%lf", &n, &an);		
		p[n] += an; 
	}
	
	for (int i = 0; i < 1005; i++)
	{
		if (p[i] != 0)
			count++;   //统计非零项的项数;
	}
	
	printf ("%d", count);
	for (int i = 1005 - 1; i >= 0; i--)
	{
		if (p[i] != 0)
			printf (" %d %.1f", i, p[i]);	//总结各类型的输出空格的方式;
	}
	
	return 0;
 } 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值