A1011. World Cup Betting (20)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.0  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
Sample Output
T T W 37.98 

题目大意:

世界杯足彩三串一,赔率为三场赔率相乘的%65,输入三场球胜负平的赔率,求最大期望收入(每注两元);

代码如下:

#include <cstdio>

char mp[3] = {'W', 'T', 'L'};
int main()
{
	double f[5], s[5], t[5];
	double temp = 0;
	int j1, j2, j3;

	for (int i = 0; i < 3; i++) {
		scanf ("%lf", &f[i]);
		if (f[i] > temp) {
			temp = f[i];
			j1 = i;
		}
	}
	temp = 0;
	for (int i = 0; i < 3; i++) {
		scanf ("%lf", &s[i]);
		if (s[i] > temp) {
			temp = s[i];
			j2 = i;
		}
	}
	temp = 0;
	for (int i = 0; i < 3; i++) {
		scanf ("%lf", &t[i]);
		if (t[i] > temp) {
			temp = t[i];
			j3 = i;
		}
	}
	printf ("%c %c %c ", mp[j1], mp[j2], mp[j3]);
	printf ("%.2f", (f[j1] * s[j2] * t[j3] * 0.65 -1) * 2);

 	return 0;
}

改进:

赔率读入后直接进行运算,不存储后再运算;

代码如下:

#include <cstdio>

char mp[3] = {'W', 'T', 'L'};

int main() { 
	double ans = 1.0, temp, a; 
	int max;                                //记录赔率最大值的下标; 
	for (int i =0; i < 3; i++) {
		temp = 0.0;
		for (int j = 0; j < 3; j++) {
			scanf ("%lf", &a);
			if (a > temp) {
				temp = a;
				max = j;
			}
		}
		ans *= temp;
		printf ("%c ", mp[max]);            //输出赔率最大的比赛结果;
	}
	
	printf ("%.2f", (ans * 0.65 - 1) * 2);

 	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值