Fence Repair

Problem Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn\'t own a saw with which to cut the wood, so he mosies over to Farmer Don\'s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn\'t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

 

Input

 Line 1: One integer N, the number of planks 

Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

 

Output

 Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

 

Sample Input

3
8
5
8

Sample Output

34

/*
  网上的解题思路:
  利用Huffman思想,要使总费用最小,那么每次只选取最小长度的两块木板相加,再把这些“和”累加到总费用中即可
  本题虽然利用了Huffman思想,但是直接用HuffmanTree做会超时,可以用优先队列做(有待学习)
  因为朴素的HuffmanTree思想是:
  (1)先把输入的所有元素升序排序,再选取最小的两个元素,把他们的和值累加到总费用
  (2)把这两个最小元素出队,他们的和值入队,重新排列所有元素,重复(1),直至队列中元素个数<=1,则累计的费用就是最小费用
  
   HuffmanTree超时的原因是每次都要重新排序,极度浪费时间,即使是用快排。
  
  一个优化的处理是:
  (1)只在输入全部数据后,进行一次升序排序  (以后不再排序)
  (2)队列指针p指向队列第1个元素,然后取出队首的前2个元素,把他们的和值累计到总费用,再把和值sum作为一个新元素插入到队列适当的位置
       由于原队首的前2个元素已被取出,因此这两个位置被废弃,我们可以在插入操作时,利用后一个元素位置,先把队列指针p+1,使他指向第2个废弃元素的位置,
       然后把sum从第3个位置开始向后逐一与各个元素比较,若大于该元素,则该元素前移一位,否则sum插入当前正在比较元素
      (队列中大于等于sum的第一个元素)的前一个位置
  (3)以当前p的位置作为新队列的队首,重复上述操作
 
   
 另一种处理方法是利用STL的优先队列,priority_queue,非常方便简单高效,虽然priority_queue的基本理论思想还是上述的优化思想,但是STL可以直接用相关的功能函数实现这些操作,
 相对简单
 注意priority_queue与qsort的比较规则的返回值的意义刚好相反
 */

//代码一:哈夫曼树正常代码(会超时)


#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<malloc.h>
using namespace std;
  int queue[60000];
int main()
{
    int n;
    scanf("%d",&n);
        int a;
        int sum=0;//哈弗曼码树
        int k=0;
        int count=0;
        for(int i=0;i<n;i++)//将字符个数保存起来
        {
                scanf("%d",&a);
                queue[k++]=a;
        }
        while(k-count>=2)//注意边界循环条件
        {
            sort(queue+count,queue+k);//排序的范围
            int x1=queue[count];
            count++;
            int x2=queue[count];
            count++;
            queue[k++]=x1+x2;
            sum+=x1+x2;
        }
        printf("%d\n",sum);//输出时强制类型转换
    return 0;
}

//代码二:优化代码(转)

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

int main()
{
    int *a;
    int i,j,n,sum;
    __int64 ans;   //不用64位过不了
    while(~scanf("%d",&n))
    {
        a=new int[n];   //每个模板的价值
        for(i=0; i<n; ++i)
            scanf("%d",&a[i]);
        sort(a,a+n);
        ans=0;
        for(i=0; i<n-1; ++i)
        {
            sum=a[i]+a[i+1];
            ans+=sum;
            for(j=i+2; j<n; ++j)
            {
                if(sum>a[j])
                    a[j-1]=a[j];
                else
                {
                    a[j-1]=sum;
                    break;
                }
            }
            if(j==n)   //说明sum比所有元素都大,把sum直接放在最后
                a[j-1]=sum;
        }
        printf("%I64d\n",ans);;
    }
    return 0;
}

//代码三:----STL  优先队列----(转)

/*STL 优先队列*/

//Memory Time

//512K   47MS

#include<iostream>
#include<vector>
#include<queue>
using namespace std;
class cmp//比较规则,最小优先
{
public:
    bool operator()(const __int64 a,const __int64 b)const
    {
        return a>b;
    }
};
int main(void)
{
    int n;  //需要切割的木板个数
    while(cin>>n)
    {
        priority_queue<__int64,vector<__int64>,cmp>Queue;  //定义优先队列

        for(int i=1; i<=n; i++)
        {
            __int64 temp;
            scanf("%I64d",&temp);
            Queue.push(temp);       //输入要求的木板长度(费用)并入队
        }
        __int64 mincost=0;   //最小费用
        while(Queue.size()>1)  //当队列中小于等于一个元素时跳出
        {
            __int64 a=Queue.top();  //得到队首元素的值,并使其出队
            Queue.pop();
            __int64 b=Queue.top();  //两次取队首,即得到最小的两个值
            Queue.pop();

            Queue.push(a+b);  //入队
            mincost+=a+b;
        }
        printf("%I64d\n",mincost);

        while(!Queue.empty())  //清空队列
            Queue.pop();
    }
    return 0;
}

 

  • 2
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值