An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
Figure 1
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.
Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
代码:
#include<iostream>
#include<cstring>
#include<stack>
using namespace std;
stack<int> put;
int pre[35],in[35],count=0,prelen=0,inlen=0;
struct node
{
int data;
node* lchild,*rchild;
};
node* creatree(int preL,int preR,int inL,int inR)
{
if(preL>preR)
return NULL;
node* root=new node;
root->data=pre[preL];
int k;
for(k=inL;k<=inR;k++)
if(in[k]==pre[preL])
break;
int newk=k-inL;
root->lchild=creatree(preL+1,preL+newk,inL,k-1);
root->rchild=creatree(preL+newk+1,preR,k+1,inR);
return root;
}
void postorder(node *root)
{
if(root==NULL)
return ;
postorder(root->lchild);
postorder(root->rchild);
if(count==1)
printf("%d",root->data);
else
printf(" %d",root->data);
count++;//注意count的位置对结果的影响
}
int main()
{
int N;
scanf("%d",&N);
char ch[10];
for(int i=0;i<2*N;i++)
{
scanf("%s",ch);
if(strcmp(ch,"Push")==0)
{
int temp=0;
scanf("%d",&temp);
pre[prelen++]=temp;
put.push(temp);
}
else if(put.size()!=0)
{
in[inlen++]=put.top();
put.pop();
}
}
node* root=creatree(0,N-1,0,N-1);
postorder(root);
return 0;