HDU 3032 Nim or not Nim?


Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap. 

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not. 

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.
Input
Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s 0 0, s 1 1, ...., s N1 N−1, representing heaps with s 0 0, s 1 1, ..., s N1 N−1 objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S i i ≤ 2^31 - 1)
Output
For each test case, output a line which contains either "Alice" or "Bob", which is the winner of this game. Alice will play first. You may asume they never make mistakes.
Sample Input
2
3
2 2 3
2
3 3
Sample Output
Alice
Bob

Lasker's Nim游戏:每一轮允许两会中操作之一:①、从一堆石子中取走任意多个,②、将一堆数量不少于2的石子分成都不为空的两堆。

很明显:sg(0) = 0,sg(1) = 1。
    状态2的后继有:0,1和(1,1),他们的SG值分别为0,1,0,所以sg(2) =2。
    状态3的后继有:0、1、2、(1,2),他们的SG值分别为0、1、2、3,所以sg(3) = 4。

    状态4的后继有:0、1、2、3、(1,3)和(2,2),他们的SG值分别为0,1,2,4,5,0,所以sg(4) = 3.

由数学归纳法可以得出

sg(4k)=4k-1;sg(4k+1)=4k+1;sg(4k+2)=4k+2;sg(4k+3)=4k+4;

通过SG函数打表可以发现规律。
当n=4*k时,sg[n] = n-1;
当n= 4*k+3 时,sg[n] = n+1;
其余sg[n] = n;

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
using namespace std;
const int MAXN = 10000;
int SG(int x)
{
    if(x == 0)return x;
    if(x % 4 == 0)return x-1;
    if(x % 4 == 3)return x+1;
    return x;
}
int main()
{
    int T;
    int n,a;
    int sum;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        sum = 0;
        for(int i = 0;i < n;i++)
        {
            scanf("%d",&a);
            sum ^= SG(a);
        }
        if(sum == 0)printf("Bob\n");
        else printf("Alice\n");
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值