题目1034:寻找大富翁

题目1034:寻找大富翁

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:5053

解决:2047

题目描述:
    浙江桐乡乌镇共有n个人,请找出该镇上的前m个大富翁.
输入:
    输入包含多组测试用例.
    每个用例首先包含2个整数n(0<n<=100000)和m(0<m<=10),其中: n为镇上的人数,m为需要找出的大富翁数, 接下来一行输入镇上n个人的财富值.
    n和m同时为0时表示输入结束.
输出:
    请输出乌镇前m个大富翁的财产数,财产多的排前面,如果大富翁不足m个,则全部输出,每组输出占一行.
样例输入:
3 1
2 5 -1
5 3
1 2 3 4 5
0 0
样例输出:
5
5 4 3
参考代码:
</pre><p><pre name="code" class="java">import java.util.Arrays;
import java.util.Collection;
import java.util.Collections;
import java.util.Scanner;


public class Main {
	//private static final Integer[] Integer = null;


	public static void main(String arg[]){
		
		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()){
			int n = sc.nextInt();
			int m = sc.nextInt();
			if(m==0 && n==0) break;
			//Person[] persons = new Person[n];
			Integer[] persons = new Integer[n];
			for(int i=0;i<n;i++)
			{
				//persons[i]=new Person(sc.nextInt());
				persons[i] = sc.nextInt();
			}
			//sortPerson(persons);
			Arrays.sort(persons,Collections.reverseOrder());
			
			for(int i=0;i<Math.min(persons.length, m);i++){
				System.out.print(persons[i]);
				if(i!=Math.min(persons.length, m)-1) System.out.print(" ");
			}
			System.out.println();		
		}		
	}	
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值