题目1039:Zero-complexity Transposition

题目1039:Zero-complexity Transposition

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:2756

解决:1101

题目描述:

You are given a sequence of integer numbers. Zero-complexity transposition of the sequence is the reverse of this sequence. Your task is to write a program that prints zero-complexity transposition of the given sequence.

输入:

For each case, the first line of the input file contains one integer n-length of the sequence (0 < n ≤ 10 000). The second line contains n integers numbers-a1, a2, …, an (-1 000 000 000 000 000 ≤ ai ≤ 1 000 000 000 000 000).

输出:

For each case, on the first line of the output file print the sequence in the reverse order.

样例输入:
5
-3 4 6 -8 9
样例输出:
9 -8 6 4 -3
参考代码:(开始用字符串分割,无论如何AC不了,用大数即可,先用字符串分割再转大数也不行)

import java.math.BigInteger;
import java.util.*;


public class Main{
	public static void main(String arg[]){
		
		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()){
			
			Integer n = sc.nextInt();
			
			List<BigInteger> num = new ArrayList<BigInteger>();
			for(int i=0;i<n;i++)
				num.add(sc.nextBigInteger());
			Collections.reverse(num);
			
			for(int i=0;i<num.size();i++){
				System.out.print(num.get(i));
				if(i!=num.size()-1) System.out.print(" ");
			} 
			System.out.println();
			//System.out.println(String.join(" ", num));

		}
	}
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值