题目1070:今年的第几天?

题目1070:今年的第几天?

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:3450

解决:1913

题目描述:

输入年、月、日,计算该天是本年的第几天。

输入:

包括三个整数年(1<=Y<=3000)、月(1<=M<=12)、日(1<=D<=31)。

输出:
输入可能有多组测试数据,对于每一组测试数据,
输出一个整数,代表Input中的年、月、日对应本年的第几天。
样例输入:
1990 9 20
2000 5 1
样例输出:
263
122
参考代码:

import java.util.*;

public class Main {
	
	public static void main(String arg[]) {
	
		int[] month1={31,28,31,30,31,30,31,31,30,31,30,31};
		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()){
		int totaldays=0;
		int year = sc.nextInt();
		//闰年判断
		int flag=0;
		if((year%100!=0&&year%4==0) || year%400==0) flag=1;
		
		int month = sc.nextInt();	
		for(int i=0;i<month-1;i++) totaldays +=month1[i];
		int day = sc.nextInt();
		totaldays = totaldays+day+flag;
		System.out.println(totaldays);;
		}        
	}
}	


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值