1038. Recover the Smallest Number (30)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287
思路是排序时比较2个字符串在其长度范围内大小,如果一个数比完了的话,即一个数是另一个数的子串,例如"321"和"3214"
那么就重新比较较长的字符串的剩余字符串和原来的较短字符串,即比较"4"和"321",这里递归用cmp函数实现了;至于这样
比较的缘由,分析321为什么在3214前面可以看出如果321在前那么第四位是3而3214在前第三位为4,所以比较的是除了相同
位之后的位数与较短的数字第一位比较;

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>

using namespace std;

bool cmp(const string &a, const string &b)
{
    int i, minsize;
    minsize = min(a.size(), b.size());
    for(i=0; i<minsize; i++)
    {
        if(a[i] != b[i])
            return a[i] < b[i];
    }
    if(i == minsize)
    {
        string x;
        if(a.size() > b.size())
        {
            x = a.substr(b.size());//截取剩余部分
            return cmp(x, b);
        }
        else if(a.size() < b.size()){
            x = b.substr(a.size());
            return cmp(a, x);
        }
    }
    return false;
}

int main()
{
    int n, m;
    vector<string> v1;
    string temp;
    string res;
    cin >> n;
    for(int i=0; i<n; i++)
    {
        cin >> temp;
        v1.push_back(temp);
    }
        sort(v1.begin(), v1.end(), cmp);
    for(int i=0; i<n; i++)
    {
        res += v1[i];
    }
    for(m=0; res[m]=='0'; m++);
    if(m == res.size())
        res = "0";
    else
        res = res.substr(m);
    cout << res << endl;
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
ECDSA.recover is a function in the ECDSA (Elliptic Curve Digital Signature Algorithm) cryptographic system that allows a user to recover the public key from a given signature and message. This function is useful in situations where the public key is unknown but the signature and message are available. The ECDSA algorithm involves three steps: key generation, signature generation, and signature verification. In the key generation step, a private key is generated using a random number generator, and the corresponding public key is derived from the private key. In the signature generation step, a message is hashed and signed using the private key to generate a signature. In the signature verification step, the signature is verified using the public key to ensure that it was generated by the owner of the private key. In some cases, the public key may not be available, but the signature and message are known. In such cases, the ECDSA.recover function can be used to recover the public key from the signature and message. The function takes three inputs: the message, the signature, and the recovery parameter. The recovery parameter is a number between 0 and 3 that specifies which of the four possible public keys should be recovered from the signature. Once the public key is recovered, it can be used to verify the signature and authenticate the message. Overall, ECDSA.recover is a useful function in the ECDSA cryptographic system that allows for public key recovery in situations where it is unknown but the signature and message are available.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值