A1038 Recover the Smallest Number (30分)【C语言】
用到了好多字符串的功能哦…
题目描述:
Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.
输入格式:
Each input file contains one test case. Each case gives a positive integer N (≤10 4 ) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.
输出格式:
For each test case, print the smallest number in one line. Notice that the first digit must not be zero.
输入样例:
5 32 321 3214 0229 87
输出样例:
22932132143287
实现代码:
#include <iostream>
#include <cstdio>
#include <string>
#include <algorithm>
using namespace std;
const int maxn = 10010;
string str[maxn];
bool cmp(string a, string b){
return a+b < b+a; //若不等式成立,则a排在b前面
}
int main()
{
int n;
cin >> n;
for(int i=0; i<n; ++i){
cin >> str[i];
}
sort(str, str+n, cmp);
string ans; //结果字符串
for(int i=0; i<n; ++i){
ans += str[i]; //将排序后的数字串进行拼接
}
while(ans.size()!=0 && ans[0]=='0'){
ans.erase(ans.begin()); //去除前导0
}
if(ans.size()==0) cout << 0; //去除前导0后为空,输出0
else cout << ans; //否则输出结果字符串
return 0;
}