A1038 Recover the Smallest Number (30分)【C语言】

A1038 Recover the Smallest Number (30分)【C语言】

原题链接

用到了好多字符串的功能哦…

题目描述:
Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

输入格式:
Each input file contains one test case. Each case gives a positive integer N (≤10 ​4​​ ) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

输出格式:
For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

输入样例:

5 32 321 3214 0229 87

输出样例:

22932132143287

实现代码:

#include <iostream>
#include <cstdio>
#include <string>
#include <algorithm>
using namespace std;
const int maxn = 10010;
string str[maxn];
bool cmp(string a, string b){
	return a+b < b+a; //若不等式成立,则a排在b前面 
}

int main()
{
	int n;
	cin >> n;
	for(int i=0; i<n; ++i){
		cin >> str[i];
	}
	sort(str, str+n, cmp);
	string ans; //结果字符串
	for(int i=0; i<n; ++i){
		ans += str[i]; //将排序后的数字串进行拼接 
	} 
	while(ans.size()!=0 && ans[0]=='0'){
		ans.erase(ans.begin()); //去除前导0 
	}
	if(ans.size()==0) cout << 0; //去除前导0后为空,输出0 
	else cout << ans; //否则输出结果字符串 
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值