1038 Recover the Smallest Number (30 point(s)) - C语言 PAT 甲级

1038 Recover the Smallest Number (30 point(s))

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

题目大意:

输入 N 个数字字符串,每个数字串是不超过 8 位的非负整数;

求这些数字串组成一个数字后的最小值,并输出,输出时没有前导 0;

设计思路:

贪心算法:

  • 对数字串排序,按照相邻两个字符串组成的字符串大小排序:
    • 形似 return (a + b) < (b + a);
  • 这样排序后保证了每相邻两个子串组成的数字最小,保证了最终组成的数字最小;
  • 注意前导 0 的处理,若最终组成的数是 0,也要输出一个 0;
编译器:C (gcc)
#include <string.h>

int cmp(const void *a, const void *b)
{
        char s1[17] = {0}, s2[17] = {0};
        sprintf(s1, "%s%s", (char *)a, (char *)b);
        sprintf(s2, "%s%s", (char *)b, (char *)a);
        return strcmp(s1, s2);
}

int main(void)
{
        int n;
        char num[10000][9] = {0};
        int i;

        scanf("%d", &n);
        for (i = 0; i < n; i++) {
                scanf(" %s", num[i]);
        }

        qsort(num, n, sizeof(num[0]), cmp);

        int flag = 0;
        for (i = 0; i < n && flag == 0; i++) {
                char *p = &num[i][0];
                while (*p != '\0' && flag == 0) {
                        if (*p == '0') {
                                p++;
                        } else {
                                flag = 1;
                                printf("%s", p);
                        }
                }
        }
        while (i < n) {
                printf("%s", num[i]);
                i++;
        }
        if (flag == 0) {
                printf("0");
        }
        return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值