B-number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2266 Accepted Submission(s): 1227
Problem Description
A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
Output
Print each answer in a single line.
Sample Input
13 100 200 1000
Sample Output
1 1 2 2
求从1~n包含13且能被13整除的数的个数,判断包含13保存上一位,判断整除13保存余数。
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define LL long long
int p[20];
LL dp[20][15][15][3];
LL dfs(int h,int last,int m,bool ok,bool sign){
if(h<0) {
if(m==0 && ok) return 1;
return 0;
}
if(!sign && dp[h][last][m][ok]!=-1) return dp[h][last][m][ok];
int end = sign?p[h]:9;
LL ans = 0;
for(int i=0;i<=end;i++){
if(last==1 && i==3) ans += dfs(h-1,i,(m*10+i)%13,true,sign && i==p[h]);
else ans += dfs(h-1,i,(m*10+i)%13,ok,sign && i==p[h]);
}
if(!sign) dp[h][last][m][ok] = ans;
return ans;
}
LL solve(LL n){
int cnt = 0;
while(n>0){
p[cnt++] = n%10;
n /= 10;
}
return dfs(cnt-1,0,0,false,true);
}
int main(){
LL n;
memset(dp,-1,sizeof dp);
while(cin >>n){
cout << solve(n) <<endl;
}
return 0;
}