hdu3652 B-number

108 篇文章 0 订阅

B-number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1658 Accepted Submission(s): 906


Problem Description
A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.

Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).

Output
Print each answer in a single line.

Sample Input
  
  
13 100 200 1000

Sample Output
  
  
1 1 2 2
数位dp,要判定mol13为0才行!
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
#define M 23
int dp[M][15][3],pri[M];
int get(int t,int i){
    if(t==2||(t==1&&i==3))return 2;
    if(i==1)return 1;
    return 0;
}
int dfs(int  pos,int pre,int t,int flag ){
    if(pos==0)return pre==0&&t==2;
    if(!flag&&dp[pos][pre][t]!=-1)return dp[pos][pre][t];
    int ans=0,u=flag?pri[pos]:9;
    for(int i=0;i<=u;i++){
    ans+=dfs(pos-1,(pre*10+i)%13,get(t,i),flag&&i==u);
    //printf("%d %d %d\n",ans,pos,i);
    }
    return flag?ans:dp[pos][pre][t]=ans;
}
int solve(int x){
    int cnt=0;
    while(x){
        pri[++cnt]=x%10;
        x/=10;
    }
    return dfs(cnt,0,0,1);
}
int main()
{
    int n;
    memset(dp,-1,sizeof(dp));
    while(scanf("%d",&n)!=EOF){
        printf("%d\n",solve(n));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值