B-number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1497 Accepted Submission(s): 820
Problem Description
A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
Output
Print each answer in a single line.
Sample Input
13 100 200 1000
Sample Output
1 1 2 2
Author
wqb0039
Source
Recommend
lcy
#include<cstdio>
#include<cstring>
#include<iostream>
#define FOR(i,a,b) for(int i=a;i<=b;++i)
#define clr(f,z) memset(f,z,sizeof(f))
using namespace std;
int dp[15][10][15][2];//位数,最后一个数,模剩数,是否有13
int bit[15],pos;
int DP(int pp,int ee,int mod,bool has,bool big)
{
if(pp==0)return (mod==0&&has);
if(big&&dp[pp][ee][mod][has]!=-1)
return dp[pp][ee][mod][has];
int ret=0;
int kn=big?9:bit[pp];
FOR(i,0,kn)
{
ret+=DP(pp-1,i,(mod*10+i)%13,has||(ee==1&&i==3),big||(bit[pp]!=i));
}
if(big)dp[pp][ee][mod][has]=ret;
return ret;
}
int get(int x)
{ pos=0;
while(x)
{
bit[++pos]=x%10;x/=10;
}
clr(dp,-1);
return DP(pos,0,0,0,0);
}
int main()
{
int n;
while(cin>>n)
{
cout<<get(n)<<endl;
}
}