POJ Power Strings

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

题目大意

给你任意个长度<=1000000的字符串,求每个字符串有多少个循环节。输入以输入一个“.”结束。

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题解

用kmp求next数组,通过该数组可以看出该字符串中的循环节。若字符串长度l不能整除循环节长度m,则输出1,否则输出l/m。
#include<cstdio>
#include<iostream>
#include<cstring>
#include<cstdlib>
#include<cmath>
using namespace std;
char a[1000005];
int next[1000005],l;
void prep()
{
	next[1]=0; int j=0;
	for(int i=2;i<=l;i++)
	   {while(j>0&&a[i]!=a[j+1]) j=next[j];
	    if(a[i]==a[j+1]) j++;
	    next[i]=j;
	   }
}
int main()
{
	while(scanf("%s",a+1)!=EOF)
	   {if(a[1]=='.') break;
	    l=strlen(a+1);
	    prep();
	    if(l%(l-next[l])==0) printf("%d\n",l/(l-next[l]));
	    else printf("1\n");
	   }
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值