bfs/广度优先搜索实例

Catch That Cow

Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

#include <cstdio>
#include <iostream>
#include <queue>
#include <algorithm>
#include <cstring>
using namespace std;

struct pos
{
    int x;//当前位置
    int _count;//当前步数
    bool v;//为0为当前节点未遍历
} p[200000];
int n, k;
queue<pos>q;//建立队列q

int bfs ();

int main ()
{
    cin>>n>>k;

    memset (p, 0, 200000*sizeof(pos));
    p[n].x=n;
    p[n]._count=0;
    p[n].v=1;
    q.push(p[n]);//第一个元素进入队列

    cout<<bfs ()<<endl;
}

int bfs ()
{
    int xx, cc;
    while (!q.empty())//队列不为空
    {
        xx=q.front().x;
        cc=q.front()._count;
        q.pop();//取得此节点的值后删除此节点

        if(xx==k)
            return cc;//追到牛了,返回步数

        if(xx>0 && p[xx-1].v==0)//人任何时候都可以减一,但人只有在牛左边的时候才能加一或者乘二
        {
            p[xx-1].v=1;
            p[xx-1].x=xx-1;
            p[xx-1]._count=cc+1;
            q.push(p[xx-1]);//将此节点插入队列
        }

        if(xx<k && p[xx+1].v==0)
        {
            p[xx+1].v=1;
            p[xx+1].x=xx+1;
            p[xx+1]._count=cc+1;
            q.push(p[xx+1]);
        }

        if(xx<k && p[xx*2].v==0)
        {
            p[xx*2].v=1;
            p[xx*2].x=xx*2;
            p[xx*2]._count=cc+1;
            q.push(p[xx*2]);
        }
    }

    return 0;
}

哎。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值