Augular引入JQuery报错-版本问题

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/q290994/article/details/81040583
背景

惭愧呀惭愧,照视频配置环境、进行开发配置之后,一运行,果断报错;网上搜罗一大堆问题解决办法,始终找不到相应办法,重新建项目并开发配置之后,还是报错,不进行配置没问题,一配置就报错,高手过来看了两眼后说:这视频和电脑的augular可能版本不一样,配置方法就不一样。
这里写图片描述

再回去视频开头查看package.json文件:
视频:
这里写图片描述

本地:
这里写图片描述

原因终于找出来了,视频中使用的augular版本是4.0,而本地使用的是2.3版本,版本不同有些规则就可能不一样,最终导致按视频敲却执行不成功的情况

总结

区别显而易见,但是能够快速、高效找到不一样的点就非常重要了。博主花了两天时间刨根问底,重装了多个版本augular和node.js,偶然之间才发现区别。所以养成对问题进行分析的习惯,会节省很多的时间。

阅读更多
想对作者说点什么? 我来说一句
相关热词

没有更多推荐了,返回首页