HDU 2058 The sum problem(数学)

The sum problem
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 28609 Accepted Submission(s): 8604

Problem Description
Given a sequence 1,2,3,……N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.

Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

Sample Input
20 10
50 30
0 0

Sample Output
[1,4]
[10,10]

[4,8]
[6,9]
[9,11]
[30,30]

[分析]
数学题
差为1的等差数列。
公式:Sn=(a1+an)*n/2(注意,后面说的n和题目中的N是不同的n,这里的n代表长度,代码中为len)
超大数字,容易TLE,诀窍在于找出小数字,而后枚举。
关键的小数字是公式中的n
也就是数列的长度,这个不大,小于sqrt(2*m)
至于为什么是sqrt(2*m),这个解释起来有点麻烦,需要思考。将公式变形,将n移项后得
2*m/(a1+an)=n
因为a1+an必然大于n所以,n必然小于sqrt(2*m)。

所以枚举n就可以

[代码]

#include<cstdio>
#include<cmath>
int main()
{
    int n, m;
    while (scanf("%d %d", &n, &m) != EOF)
    {
        if (!n && !m)break;
        int len = sqrt(2 * m)+1;
        //printf("%d\n", len);
        while (--len)
        {
            int a = (2 * m) / len - len + 1;
            a = a / 2;
            if (len*(2 * a + len - 1) / 2 == m)printf("[%d,%d]\n", a, a + len - 1);
        }
        printf("\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值