hdu 2069 二维母函数

Problem Description
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.

Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.

Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input
11
26

Sample Output
4
13

题意:

能不能用1 5 10 25 50 组成输入的数,并且使用的个数不能超过100个

题解:

多加一维维护个数。c1[i][j] 表示 c1[结果][组成该结果的个数]。
预处理优化一下。

代码:

#include <bits/stdc++.h>

using namespace std;
int c1[251][101];
int c2[251][101];//次数顶多为250 前一个括号是指系数 后一个指硬币个数
int val[6]={0,1,5,10,25,50};

int main()
{
    memset(c1,0,sizeof(c1));
    memset(c2,0,sizeof(c2));
    int i,j,k,n,l,sum;
    for(i=0;i<=100;i++)
    {
        c1[i][i]=1;
    }
    n=250;
    for(i=2;i<=5;i++)
    {
        for(j=0;j<=n;j++)
            for(k=0;k+j<=n;k+=val[i])
             for(l=0;l+k/val[i]<=100;l++)
               c2[k+j][l+k/val[i]]+=c1[j][l];

        for(k=0;k<=n;k++)
            for(l=0;l<=100;l++)
        {
            c1[k][l]=c2[k][l];
            c2[k][l]=0;
        }
    }

    while(cin>>n)
    {
        sum=0;
        for(i=0;i<=100;i++)
            sum+=c1[n][i];
        cout<<sum<<endl;
    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值