HDU 1482 模拟天平问题

Counterfeit Dollar

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 523    Accepted Submission(s): 198


Problem Description
Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins. 

Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively. 


By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings. 

 

Input
The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A-L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.
 

Output
For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.
 

Sample Input
      
      
1 ABCD EFGH even ABCI EFJK up ABIJ EFGH even
 

Sample Output
      
      
K is the counterfeit coin and it is light.
 

Source
 

Recommend
xhd   |   We have carefully selected several similar problems for you:   2722  1385  2482  2433  2962 
 


题意: 有12枚硬币,其中有一枚质量与其他十一枚不同,可能轻可能重,通过系统给你的三次称量结果找出那枚硬币 并说出是轻是重 ,看上去很水,实际上也很水,须细心考虑。

题解: 1.  出现"even"代表两边肯定是真币,优先级最高

             2.  出现质量不同的情况,可能两边都可能是假币,优先级次于 1;

             3.  之前出现在轻的一边,后来又出现在重的一边的为真币,优先级最高

             4.  每一次假币出现,必定造成质量不相等,反之亦然

代码:

#include<stdio.h>
#include<iostream>
#include<map>
using namespace std;
struct dian
{
  int flag,mg;   
  int mark;   
}cun[12];
int main()
{
  int T;
  char a[15],b[15],c[10];
  scanf("%d",&T);
  while(T--)
     {
       memset(cun,0,sizeof(cun));
       int num=0;
       for(int i=0;i<3;i++)
         {
           scanf("%s%s%s",a,b,c);
           int lena=strlen(a);
           int lenb=strlen(b);
           if(lena==lenb&&!strcmp(c,"even"))
             {
                for(int j=0;j<lena;j++)
                 {
                  cun[a[j]-'A'].flag=1;
                  cun[a[j]-'A'].mg=0;
                 }
                for(int j=0;j<lenb;j++)
                 {
                  cun[b[j]-'A'].flag=1;  
                  cun[b[j]-'A'].mg=0;
                 }                         
             }      
           if(lena==lenb&&strcmp(c,"even"))
             {
               num++;
               for(int j=0;j<lena;j++)
                 {
                   if(!cun[a[j]-'A'].flag&&!strcmp(c,"up"))  
                       if(cun[a[j]-'A'].mg==1) 
                         {
                           cun[a[j]-'A'].flag=1;
                           cun[a[j]-'A'].mg=0;                     
                         }
                       else{ cun[a[j]-'A'].mg=2;cun[a[j]-'A'].mark++;}
                   if(!cun[a[j]-'A'].flag&&!strcmp(c,"down")) 
                       if(cun[a[j]-'A'].mg==2)  
                         {
                           cun[a[j]-'A'].flag=1;
                           cun[a[j]-'A'].mg=0;                       
                         }  
                       else {cun[a[j]-'A'].mg=1;cun[a[j]-'A'].mark++;}
                 }                                                        
                for(int j=0;j<lenb;j++)
                 {
                   if(!cun[b[j]-'A'].flag&&!strcmp(c,"up"))  
                       if(cun[b[j]-'A'].mg==2) 
                         {
                           cun[b[j]-'A'].flag=1;
                           cun[b[j]-'A'].mg=0;                     
                         }
                       else {cun[b[j]-'A'].mg=1;cun[b[j]-'A'].mark++;}
                   if(!cun[b[j]-'A'].flag&&!strcmp(c,"down")) 
                       if(cun[b[j]-'A'].mg==1)  
                         {
                           cun[b[j]-'A'].flag=1;
                           cun[b[j]-'A'].mg=0;                       
                         }  
                       else {cun[b[j]-'A'].mg=2;cun[b[j]-'A'].mark++;}
                 }                            
             }
         }  
        for(int i=0;i<=11;i++)
           if(!cun[i].flag&&cun[i].mg&&cun[i].mark==num)
              if(cun[i].mg==1)
                {
                   printf("%c is the counterfeit coin and it is light.\n",i+'A');
                   break;           
                }
              else 
                {
                   printf("%c is the counterfeit coin and it is heavy.\n",i+'A');
                   break;                    
                }
                   
     }    
}

附送一组测试数据:

ABCDEF GHIJKL up 
ABC DEF even 
I J down 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值