How many prime numbers

How many prime numbers

 
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10878 Accepted Submission(s): 3566
 
Problem Description
Give you a lot of positive integers, just to find out how many prime numbers there are.
 
Input
There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
 
Output

            For each case, print the number of prime numbers you have found out.
 
Sample Input
3
2 3 4
 
Sample Output
2
 
Author
wangye
 
Source
HDU 2007-11 Programming Contest_WarmUp
打表会超时,够坑 发火
#include<iostream>  
    #include<math.h>  
    using namespace std;  
    #define N 100000000  
    int main()  
    {  
        int n,b,s,f,i;  
        while(scanf("%d",&n)!=EOF)  
        {  
            s=0;  
            while(n--)  
            {  
                scanf("%d",&b);  
                f=0;  
                for(i=2;i<=sqrt(b*1.0);i++)  
                    if(b%i==0)  
                    {f=1;break;}  
                    if(!f)s++;  
            }  
            printf("%d\n",s);  
        }  
        return 0;  
    }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值