HDU(1016)搜索Prime Ring Problem

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42265    Accepted Submission(s): 18729


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
深搜算法:
找出一个环,使其临近的两数之和为质数,并按字典数排序:
从二开始搜索,把符合的数存在数组中,并标记已访问,注意细节
Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
Asia 1996, Shanghai (Mainland China)
#include<stdio.h>
#include<cstring.h>
#include<iostream>

using namespace std;
int v[25],num[25];
int n;
int prime[50]={0,1,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1,0,0,0,1,0,1,0,0,0,1,0,0};
void dfs(int m)
{
	if(m==n&&prime[num[0]+num[m-1]])//判断输出条件
	{
		for(int i=0;i<n-1;i++)
		printf("%d ",num[i]);
		printf("%d\n",num[n-1]);
	}
	else
	for(int i=2;i<=n;i++)//从2开始搜索
	{
		if(!v[i]&&prime[i+num[m-1]])
		{
			num[m++]=i;
			v[i]=1;//标记已搜索
			dfs(m);
			v[i]=0;//清除标记
			m--;
			
		}
	}
}
int main()
{
	memset(v,0,sizeof(v));
	int t=1;
	while(~scanf("%d",&n))
	{
		printf("Case %d:\n",t);
		t++;
		num[0]=1;
		dfs(1);
		printf("\n");
	}
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值