hdu 1016 Prime Ring Problem

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1016

 

题目描述:

 

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

 

Input

n (0 < n < 20).

 

 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

 

 

Sample Input

 

6 8

 

 

Sample Output

 

Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2

 

 

 

 

题目分析:

经典dfs,也是我自己裸敲的第一个dfs,成就感爆棚啊!还需继续努力

 

AC代码:

 

#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
const int maxn=20;
int v[maxn];
int n;
int cas=1;

bool su(int x)//判断是不是素数
{
    for(int i=2;i<=sqrt(x);i++)
    {
        if(x%i==0)
            return false;
    }
    return true;
}

void Print()
{
    for(int i=1;i<=n;i++)
    {
        printf("%d",v[i]);
        if(i!=n)
          printf(" ");
        else
          printf("\n");
    }
}

void dfs(int m)//已填m个数
{
    if(m==n)
        Print();
    int i,j;
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=m;j++)
        {
           if(v[j]==i)
                break;
        }
        if(j==(m+1))
        {
            if(m+1<n)
            {
                if(su(i+v[m]))
                    {
                        v[m+1]=i;
                        dfs(m+1);
                    }
            }
            if(m+1==n)
            {
                if(su(i+v[m])&&su(i+v[1]))
                    {
                        v[m+1]=i;
                        dfs(m+1);
                    }
            }
        }
    }
}

int main()
{
    v[1]=1;
    while(cin>>n)
    {
        printf("Case %d:\n",cas++);
        dfs(1);
        printf("\n");
    }
    return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值