Description
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires Tseconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Sample Input
2 3 3 1 1 2 2 1 3 4 2 3 1 3 1 3 3 2 1 1 2 3 2 3 4 3 1 8
Sample Output
NO YES
Hint
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
给出m条正权边,为无向边,w条负权边,为有向边,问是否存在负权回路;
负权回路:
一个图有n个点,最多有n-1条边,若无负权回路时两两点之间最短距离可以通过n-1次更新距离求的,若第n次仍可更新距离时,则存在负权回路;
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
int n,m,t,w,a[3000],k;
struct none
{
int st;
int end;
int time;
}lu[3000];
int judge()
{
int p=0;
for(int i=0;i<=n;i++)
a[i]=100000000;
for(int j=0;j<n-1;j++)
{
p=0;
for(int i=0;i<k;i++)//更新
{
if(a[lu[i].st]+lu[i].time<a[lu[i].end])
{a[lu[i].end]=a[lu[i].st]+lu[i].time;
p=1;
}
}
if(p==0)
return 0;
}
for(int i=0;i<k;i++)
if(a[lu[i].st]+lu[i].time<a[lu[i].end])
return 1;
return 0;
}
int main()
{
scanf("%d",&t);
while(t--)
{ k=0;
scanf("%d%d%d",&n,&m,&w);
for(int i=0;i<m;i++)
{
scanf("%d%d%d",&lu[k].st,&lu[k].end,&lu[k].time);
k++;
lu[k].st=lu[k-1].end;
lu[k].end=lu[k-1].st;
lu[k].time=lu[k-1].time;
k++;
}
for(int i=0;i<w;i++)
{
scanf("%d%d%d",&lu[k].st,&lu[k].end,&lu[k].time);
lu[k].time=0-lu[k].time;
k++;
}
if(judge())
printf("YES\n");
else
printf("NO\n");
}
}