POJ 3259 Wormholes 【spfa 负权回路】

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 58541 Accepted: 21881

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
判断是否存在负权回路;
spfa模板题,只需在每次pop时记录次数,如果次数已经大于等于n;
那么一定存在负权回路;
#include<vector>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
#define mms(x, y) memset(x, y, sizeof x)
#define MAX 1000
#define INF 0x3f3f3f3f
struct edge
{
    int to, c;
};
int times[MAX];
int vis[MAX];
int dis[MAX];
int n, m, w;
queue <int> q;
vector <edge> v[MAX];
void ADD(int x, int y, int z)
{
    v[x].push_back({y, z});
}
void add(int x, int y, int z)
{
    ADD(x, y, z);
    ADD(y, x, z);
}
void init()
{
    mms(times, 0);
    mms(vis, 0);
    for(int i = 1; i <= MAX; i++)
    {
        dis[i] = INF;
        v[i].clear();
    }
    while(!q.empty())
        q.pop();
}
bool spfa(int s)
{
    dis[s] = 0;
    q.push(s);
    vis[s] = 1;
    while(!q.empty())
    {
        int u = q.front();
        q.pop();
        vis[u] = 0;
        times[u]++;
        if(times[u] >= n)
            return 1;
        int len = v[u].size();
        for(int i = 0; i < len; i++)
        {
            int to = v[u][i].to;
            int c = v[u][i].c;
            if(dis[to] > dis[u] + c)
            {
                dis[to] = dis[u] + c;
                if(!vis[to])
                {
                    q.push(to);
                    vis[to] = 1;
                }
            }
        }
    }
    return 0;
}
int main()
{
    int M;
    scanf("%d", &M);
    while(M--)
    {
        init();
        scanf("%d%d%d", &n, &m, &w);
        for(int k = 0, x, y, z; k < m; k++)
        {
            scanf("%d%d%d", &x, &y, &z);
            add(x, y, z);
        }
        for(int k = 0, x, y, z; k < w; k++)
        {
            scanf("%d%d%d", &x, &y, &z);
            ADD(x, y, -z);
        }
        if(spfa(1))
            puts("YES");
        else
            puts("NO");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值