uva 340 Master-Mind Hints(数组应用--密码契合)

题目描述:

MasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker,tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the playersagree upon the length N that a code must have and upon the colors that may occur in a code.In order to break the code, Breaker makes a number of guesses, each guess itself being a code. Aftereach guess Designer gives a hint, stating to what extent the guess matches his secret code.In this problem you will be given a secret code s1 . . . sn and a guess g1 . . . gn, and are to determinethe hint. A hint consists of a pair of numbers determined as follows.A match is a pair (i, j), 1 ≤ i ≤ n and 1 ≤ j ≤ n, such that si = gj . Match (i, j) is called strongwhen i = j, and is called weak otherwise. Two matches (i, j) and (p, q) are called independent wheni = p if and only if j = q. A set of matches is called independent when all of its members are pairwiseindependent.Designer chooses an independent set M of matches for which the total number of matches and thenumber of strong matches are both maximal. The hint then consists of the number of strong followedby the number of weak matches in M. Note that these numbers are uniquely determined by the secretcode and the guess. If the hint turns out to be (n, 0), then the guess is identical to the secret code.

Input

The input will consist of data for a number of games. The input for each game begins with an integerspecifying N (the length of the code). Following these will be the secret code, represented as N integers,which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, eachalso represented as N integers, each in the range 1 to 9. Following the last guess in each game will beN zeroes; these zeroes are not to be considered as a guess.Following the data for the first game will appear data for the second game (if any) beginning with anew value for N. The last game in the input will be followed by a single ‘0’ (when a value for N wouldnormally be specified). The maximum value for N will be 1000.

Output

The output for each game should list the hints that would be generated for each guess, in order, one hintper line. Each hint should be represented as a pair of integers enclosed in parentheses and separated bya comma. The entire list of hints for each game should be prefixed by a heading indicating the gamenumber; games are numbered sequentially starting with 1. Look at the samples below for the exactformat.

Sample Input

4

1 3 5 5

1 1 2 3

4 3 3 5

6 5 5 1

6 1 3 5

1 3 5 5

0 0 0 0

10

1 2 2 2 4 5 6 6 6 9

1 2 3 4 5 6 7 8 9 1

1 1 2 2 3 3 4 4 5 5

1 2 1 3 1 5 1 6 1 9

1 2 2 5 5 5 6 6 6 7

0 0 0 0 0 0 0 0 0 0

0

Sample Output

Game 1:

       (1,1)

       (2,0)

       (1,2)

       (1,2)

       (4,0)

Game 2:

       (2,4)

       (3,2)

       (5,0)

       (7,0)

Master-Mind是一种2个人的游戏。 其实就是学生常玩的几A几B的游戏(规则或许有些许不同)。 其中一个人担任出题者,他选一串1到9数字 当作密码(可以重复)。 另一个人为解题者,他要去猜密码为何。 解题者每次猜测后,出题者以某种格式回答他这次猜的结果。 在游戏开始之前,双方先协议密码的长度,假设是n。 在出题者设定密码(s1,s2,...sn) 后,由解题者来猜(g1,g2,...gn)。 如 果同样位置gi=si, 那解题者得到一个A。 如果gi=sj,但i不等于j,那解题者得到一个B。 请注意:不管是得A或得B,每个 gi最多只能对应到一个sj,而且得A比得B优先。 举例说明:密码为1 2 3 4,若猜题者猜1 1 5 6,那出题者应该回答1A0B,而不是0A1B。 如果某个猜测得到 nA0B,那就代表猜题者完全猜中密码了。

因为密码数字为1到9,计算相同位置相同数个数直接查找,查找都出现过,但位置不同暴力查找,最后减去相同位置相同数的个数

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
int a[10000],b[10000];
int main()
{
	int n,c=1;
	while(scanf("%d",&n)&&n)
	{  
		for(int i=0;i<n;i++)
		scanf("%d",&a[i]);
		 int judge=0;
		printf("Game %d:\n",c++); 
		while(judge==0)
		{
		for(int i=0;i<n;i++)
		{
			scanf("%d",&b[i]);
			if(b[i]==0)
			judge=1;
		}
		if(judge==0)
		{
			int x=0,y=0;
			for(int i=0;i<n;i++)
			{
				if(a[i]==b[i])
				x++;
			}
			int x1=0,x2=0;
			for(int i=1;i<=9;i++)
			{
				x1=0;x2=0;
				for(int j=0;j<n;j++)
				{
				if(a[j]==i)x1++;
				if(b[j]==i)x2++;
			    }
			    y+=min(x1,x2);
			}
			printf("(%d,%d)\n",x,y-x);
		}
	}
		
	}
	
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值