hdu 5360 Hiking

题意:邀请人聚会,被邀请人有两个限制that当前已经被邀请到的人数必须在[a,b]之间,否则不能被邀请,让你输出最多能邀请成功几个人,并输出一种邀请顺序

贪心+优先队列,注意一下各种边界条件。


Hiking

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1230    Accepted Submission(s): 642
Special Judge


Problem Description
There are  n  soda conveniently labeled by  1,2,,n . beta, their best friends, wants to invite some soda to go hiking. The  i -th soda will go hiking if the total number of soda that go hiking except him is no less than  li  and no larger than  ri . beta will follow the rules below to invite soda one by one:
1. he selects a soda not invited before;
2. he tells soda the number of soda who agree to go hiking by now;
3. soda will agree or disagree according to the number he hears.

Note: beta will always tell the truth and soda will agree if and only if the number he hears is no less than  li  and no larger than  ri , otherwise he will disagree. Once soda agrees to go hiking he will not regret even if the final total number fails to meet some soda's will.

Help beta design an invitation order that the number of soda who agree to go hiking is maximum.
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first contains an integer  n   (1n105) , the number of soda. The second line constains  n  integers  l1,l2,,ln . The third line constains  n  integers  r1,r2,,rn (0lirin)
It is guaranteed that the total number of soda in the input doesn't exceed 1000000. The number of test cases in the input doesn't exceed 600.
 

Output
For each test case, output the maximum number of soda. Then in the second line output a permutation of  1,2,,n  denoting the invitation order. If there are multiple solutions, print any of them.
 

Sample Input
  
  
4 8 4 1 3 2 2 1 0 3 5 3 6 4 2 1 7 6 8 3 3 2 0 5 0 3 6 4 5 2 7 7 6 7 6 8 2 2 3 3 3 0 0 2 7 4 3 6 3 2 2 5 8 5 6 5 3 3 1 2 4 6 7 7 6 5 4 3 5
 

Sample Output
  
  
7 1 7 6 5 2 4 3 8 8 4 6 3 1 2 5 8 7 7 3 6 7 1 5 2 8 4 0 1 2 3 4 5 6 7 8
 

Author
zimpha@zju
 

Source


#include <iostream>
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <stack>
using namespace std;
typedef long long LL;
const int INF=0x7fffffff;
const int MAX_N=10000;

int T,n,cur,pos;
int ans[100009];
struct people{
    int x,y,id;
    friend bool operator<(const people &a,const people &b){
        return a.y>b.y;
    }
};
people p[100009];

bool cmp1(const people &a,const people &b){
    return a.x<b.x;
}
priority_queue<people>q;

int main(){
    cin>>T;
    while(T--){
        memset(ans,0,sizeof(ans));
        memset(p,0,sizeof(p));
        while(!q.empty())q.pop();

        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%d",&p[i].x);
            p[i].id=i;
        }
        for(int i=1;i<=n;i++){
            scanf("%d",&p[i].y);
        }

        sort(p+1,p+n+1,cmp1);


        cur=0;
        pos=1;
        int backpos=n-1;
        int flag=0;
        while(1){
            flag=0;
            while(p[pos].x<=cur&&pos<=n){
                flag=1;
                q.push(p[pos]);
                pos++;

            }

            while(!q.empty()){
                flag=1;
                if(q.top().y<cur){
                    ans[backpos--]=q.top().id;
                    q.pop();
                    continue;
                }
                ans[cur]=q.top().id;
                cur++;
                q.pop();
                break;
            }
            if(flag==0)break;
        }

        for(int i=0;i<n-(pos-1);i++){
            ans[backpos--]=p[n-i].id;
        }


        printf("%d\n",cur);
        for(int i=0;i<n-1;i++){
            printf("%d ",ans[i]);
        }
        printf("%d\n",ans[n-1]);


    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值