hdu4788 水题 Hard Disk Drive (2013 Asia Chengdu Regional Contest problem H)

题意:一个人认为B、MB、GB、TB……是1000进制,另一个认为是1024进制,给你一个存储量,例如100[MB],问你两种理解方式差了百分之多少,分母是1024的。

思路:每递增一个级别,就乘个1000/1024就行了


Hard Disk Drive

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2146    Accepted Submission(s): 1172


Problem Description
  Yesterday your dear cousin Coach Pang gave you a new 100MB hard disk drive (HDD) as a gift because you will get married next year.
  But you turned on your computer and the operating system (OS) told you the HDD is about 95MB. The 5MB of space is missing. It is known that the HDD manufacturers have a different capacity measurement. The manufacturers think 1 “kilo” is 1000 but the OS thinks that is 1024. There are several descriptions of the size of an HDD. They are byte, kilobyte, megabyte, gigabyte, terabyte, petabyte, exabyte, zetabyte and yottabyte. Each one equals a “kilo” of the previous one. For example 1 gigabyte is 1 “kilo” megabytes.
  Now you know the size of a hard disk represented by manufacturers and you want to calculate the percentage of the “missing part”.
 

Input
  The first line contains an integer T, which indicates the number of test cases.
  For each test case, there is one line contains a string in format “number[unit]” where number is a positive integer within [1, 1000] and unit is the description of size which could be “B”, “KB”, “MB”, “GB”, “TB”, “PB”, “EB”, “ZB”, “YB” in short respectively.
 

Output
  For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the percentage of the “missing part”. The answer should be rounded to two digits after the decimal point.
 

Sample Input
  
  
2 100[MB] 1[B]
 

Sample Output
  
  
Case #1: 4.63% Case #2: 0.00%
Hint
 

Source



#include <iostream>
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <stack>
using namespace std;
typedef long long LL;
const int INF=0x7fffffff;
const int MAX_N=10000;

int T,a;
char A[10];
double B[20];
int main(){
    B[0]=1;
    for(int i=1;i<=8;i++){
        B[i]=B[i-1]*(1000*1.0/(1024*1.0));
    }
    cin>>T;
    int t=T;
    int ans;
    while(T--){
        scanf("%d%s",&a,A);
        char c=A[1];
        if(c=='B'){
            ans=0;
        }
        else if(c=='K')ans=1;
        else if(c=='M')ans=2;
        else if(c=='G')ans=3;
        else if(c=='T')ans=4;
        else if(c=='P')ans=5;
        else if(c=='E')ans=6;
        else if(c=='Z')ans=7;
        else if(c=='Y')ans=8;


        printf("Case #%d: %.2lf%%\n",t-T,100-B[ans]*100);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值