https://pintia.cn/problem-sets/994805260223102976/problems/994805280074743808
1043 输出PATest(20 分)
给定一个长度不超过 104 的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest....
这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出。
输入格式:
输入在一行中给出一个长度不超过 104 的、仅由英文字母构成的非空字符串。
输出格式:
在一行中按题目要求输出排序后的字符串。题目保证输出非空。
输入样例:
redlesPayBestPATTopTeePHPereatitAPPT
输出样例:
PATestPATestPTetPTePePee
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int nmax=1e4+10;
char s[nmax];
int hashtable[6];//记录“PATest"的次数;
char dic[6]={'P','A','T','e','s','t'};
int main(int argc, char** argv) {
while(cin.getline(s,nmax)){
int len=strlen(s);
int sum=0;//记录PATest序列的总长度
for(int i=0;i<len;i++){
for(int j=0;j<6;j++){
if(s[i]==dic[j]){
hashtable[j]++;
sum++;
}
}
}
while(sum>0){
for(int i=0;i<6;i++){
if(hashtable[i]>0){
printf("%c",dic[i]);
hashtable[i]--;
sum--;
}
}
}
}
return 0;
}