hdu-2767

Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.
2. Ax = b has exactly one solution for every n × 1 matrix b.
3. Ax = b is consistent for every n × 1 matrix b.
4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?
Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.
Output
Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.
Sample Input
2
4 0
3 2
1 2
1 3
Sample Output
4
2
题意:抽象题意,去除那些废话后,剩下的意思就是问最少添加多少条边使得图变成强连通。(模板题!模板题!)

题解:先求强连通分量,再把强连通分量缩成DAG,然后求出入度为0的DAG个数的最大值。这个最大值就是答案。(结果我因为一个++tot和tot++搞了一个下午,最后找到症结内心是崩溃的,然而,还是有好处的,下次就不会再犯咯)

代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <stack>
#include <cstring>
#include <vector>
#include <bitset>
#include <string>
#include <cmath>
#include <set>
#include <map>
#include <queue>
using namespace std;
typedef long long ll;
const int maxn = 2e4+7;
vector<int> g[maxn];
stack<int> s;
int n,m;
int low[maxn],dfn[maxn],vis[maxn],id[maxn];
int ind[maxn],oud[maxn];
int tot,cnt;
void tarjan(int x){
    low[x] = dfn[x] = ++tot;
    s.push(x),vis[x] =1;
    for (int i = 0;i < g[x].size();i++){
        int v = g[x][i];
        if(!dfn[v]){
            tarjan(v);
            low[x] = min(low[v],low[x]);
        }
        else if(vis[v]){
            low[x] = min(low[x],dfn[v]);
        }
    }
    if(low[x]==dfn[x]){
        cnt++;
        while (1){
            int now = s.top();
            s.pop();
            vis[now] = 0;
            id[now] = cnt;
            if(now==x) break;
        }
    }
}

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d %d",&n,&m);
        for (int i = 1;i <= n;i++) g[i].clear();
        memset(dfn,0,sizeof(dfn));
        memset(low,0,sizeof(low));
        memset(vis,0,sizeof(vis));
        memset(id,0,sizeof(id));
        tot = 0,cnt = 0;
        for (int i = 0;i < m;i++){
            int a,b;
            scanf("%d %d",&a,&b);
            g[a].push_back(b);
        }
        for (int i = 1;i <= n;i++)
        {
            if(!dfn[i]){
                tarjan(i);
            }
        }
        if(cnt==1){
            printf("%d\n",0);
            continue;
        }
        memset(ind,0,sizeof(ind));
        memset(oud,0,sizeof(oud));
        for(int i = 1;i <= n;i++){
            for (int j = 0;j < g[i].size();j++){
                int u = id[i],v = id[g[i][j]];
                if(u!=v){
                    ind[v] = oud[u] = 1;
                }
            }
        }
        int ans1 = 0,ans2 = 0;
        for (int i = 1;i <= cnt;i++){
            if(ind[i]==0) ans1++;
            if(oud[i]==0) ans2++;
        }
        printf("%d\n",max(ans1,ans2));
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值