[HDU 2767]Proving Equivalences(强连通分量)

Description


Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

  1. A is invertible.
  2. Ax = b has exactly one solution for every n × 1 matrix b.
  3. Ax = b is consistent for every n × 1 matrix b.
  4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

Input


On the first line one positive number: the number of testcases, at most 100. After that per testcase:

  • One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
  • m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

Output


Per testcase:

  • One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

Sample Input


2
4 0
3 2
1 2
1 3

Sample Output


4
2

Solution


找bug找得要崩溃
刘汝佳上的一道例题?
找强连通分量,缩点;入度为0的点数与出度为0的点数的最大值即答案,因为每加一条边增加一个入度和一个出度(特判:原图整个强连通时ans=0)

#include<cstdio>
#include<iostream>
#include<cstring>
#include<string>
#include<stack>
#define Min(a,b) (a<b?a:b)
#define Max(a,b) (a>b?a:b)
using namespace std;
int t,n,m;
int head[20005],cnt;
int dfs_clock,scc_cnt;
int pre[20005],low[20005],belong[20005];
int in[20005],out[20005];
bool instack[20005];
stack<int>s;
struct Node
{
    int next,to;
}Edges[50005]; 
void add(int u,int v)
{
    Edges[++cnt].next=head[u];
    Edges[cnt].to=v;
    head[u]=cnt;
}
void tarjan(int u)
{
    instack[u]=1;
    s.push(u);
    pre[u]=low[u]=++dfs_clock;
    for(int i=head[u];~i;i=Edges[i].next)
    {
        int v=Edges[i].to;
        if(!pre[v])
        {
            tarjan(v);
            low[u]=Min(low[u],low[v]);
        }
        else if(instack[v])
        {
            low[u]=Min(low[u],pre[v]);
        }
    }
    if(pre[u]==low[u])
    {
        ++scc_cnt;
        int v;
        do
        {
            v=s.top();
            s.pop();
            instack[v]=0;
            belong[v]=scc_cnt;
        }
        while(v!=u);
    }
}
void build()
{
    for(int i=1;i<=n;i++)
    {
        for(int j=head[i];~j;j=Edges[j].next)
        {
            int v=Edges[j].to;
            if(belong[v]!=belong[i])
            {
                in[belong[v]]++;
                out[belong[i]]++;
            }
        }
    }
}
void work()
{
    if(scc_cnt==1){
        printf("0\n");
        return;
    }
    int in0=0,out0=0,ans;
    for(int i=1;i<=scc_cnt;i++)
    {
        if(!in[i])in0++;
        if(!out[i])out0++;
    }
    ans=Max(in0,out0);
    printf("%d\n",ans);
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        memset(head,-1,sizeof(head));
        memset(pre,0,sizeof(pre));
        memset(instack,0,sizeof(instack));
        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));
        cnt=0;
        dfs_clock=scc_cnt=0;
        scanf("%d%d",&n,&m);
        int s1,s2;
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&s1,&s2);
            add(s1,s2);
        }
        for(int i=1;i<=n;i++)
        {
            if(!pre[i])tarjan(i);
        }
        build();
        work();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值