hdu 1013 Digital Roots(简单题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1013

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 64059    Accepted Submission(s): 19911


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
  
  
24 39 0
 

Sample Output
  
  
6 3
 

Source
 

Recommend
We have carefully selected several similar problems for you:   1048  1170  1015  1196  1062 
 
题目大意:将输入的数每一位详见,直到加到一位数为止,即输出这个一位数。
解题思路:很坑的一道题,本以为一位一位取出来进行相加处理,再判断一下是否是一位数字,直到是一位数输出就好了,但是思想还是太单纯!!这样只会wa~~

因为这题测试数据可能会很长,所以不能按照上述的方法,又想到用字符串的方式处理,但是开数据也是很麻烦的,所以就直接对每一个字符进行处理,也就是没得到一个字符就加到s上,如果s大于9了,马上就对s处理,个位和十位相加变成一个数。


详见代码。

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int main()
{
    char ch[1010];
    int s;
    while (~scanf("%s",ch))
    {
        if (ch[0]=='0')
            break;
        s=0;
        int len=strlen(ch);
        for (int i=0; i<len; i++)
        {
            s+=ch[i]-'0';
            if (s>=9)
            {
                s=s%10+s/10;
                //printf ("%d\n",s);
            }
        }
        printf ("%d\n",s);
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值