hdu 1541 Stars(树状数组)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1541

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7144    Accepted Submission(s): 2802


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
  
  
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
  
  
1 2 1 1 0
 

Source
 

Recommend
LL   |   We have carefully selected several similar problems for you:   3450  1542  1255  3030  1543 
 

题目大意:求出0~n-1的每个等级有多少个星星。开始输入一个n,表示共有n颗星星,接下来n行,每行输入一个x,y表示星星的坐标,最后求各个阶段星星的等级(阶段分为0~n-1)有多少个星星。
特别注意:1、星星坐标中的y是递增输入的。
    2、星星等级的计算方法是:该颗星星的左边及其下方有多少个星星,等级就为多少。
解题思路:先看一排的星星坐标,也就是先不管y,只看y值相同的星星坐标的x。设a[i]表示x轴坐标为i的点的个数。所以这里的求a[0]+a[1]+.....+a[x]的和刚好又用到的是树状数组的另一个最基本的应用-区间求和。

详见代码。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;

int c[32010];

int lowbit(int k)
{
    return k&((k)xor(k-1));
}

void add(int num,int k)
{
    while (k<=32009)
    {
        c[k]+=num;
        k+=lowbit(k);
    }
}

int sum(int k)
{
    int s=0;
    while (k)
    {
        s+=c[k];
        k-=lowbit(k);
    }
    return s;
}

int main()
{
    int n;
    int a[32000+10],w[32000+10];
    while (~scanf("%d",&n))
    {
        memset(c,0,sizeof(c));
        memset(w,0,sizeof(w));
        for (int i=0; i<n; i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            //a[x]++;//表示相同x有几个星星
            int s=sum(x+1);//求出等级
            w[s]++;//这个等级的星星有多少个
            add(1,x+1);//变化一个星星,加上1
        }
        for (int i=0; i<n; i++)
            printf ("%d\n",w[i]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值