hdu 1212 Big Number(大数取模)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1212

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7083    Accepted Submission(s): 4884


Problem Description
As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 

Output
For each test case, you have to ouput the result of A mod B.
 

Sample Input
  
  
2 3 12 7 152455856554521 3250
 

Sample Output
  
  
2 5 1521
 

Author
Ignatius.L
 

Source
 
题目大意:给你一个长度不超过1000的大数A,还有一个不超过100000的B,快速求A % B。
解题思路:第一种:按照正常除法的方法一位一位除下去即可。
     第二种:
举个例子,1314 % 7= 5
由秦九韶公式:
1314= ((1*10+3)*10+1)*10+4
所以有
1314 % 7= ( ( (1 * 10 % 7 +3 )*10 % 7 +1)*10 % 7 +4 )%7

详见代码。

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

char a[100000+10];

int main()
{
    int b;
    while (~scanf("%s%d",a,&b))
    {
        int len=strlen(a);
        int pre=0,ans;
        for (int i=0; i<len; i++)
        {
            ans=pre*10+a[i]-'0';
            pre=ans%b;
        }
        printf ("%d\n",pre);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值