poj3537 Crosses and Crosses----sg 分解游戏

Crosses and Crosses
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 1866 Accepted: 687
Case Time Limit: 2000MS

Description

The game of Crosses and Crosses is played on the field of 1 × n cells. Two players make moves in turn. Each move the player selects any free cell on the field and puts a cross ‘×’ to it. If after the player’s move there are three crosses in a row, he wins.

You are given n. Find out who wins if both players play optimally.

Input

Input file contains one integer number n (3 ≤ n ≤ 2000).

Output

Output ‘1’ if the first player wins, or ‘2’ if the second player does.

Sample Input

 
 
#13
#26

Sample Output

 
 
#11
#22

Source

Northeastern Europe 2007, Northern Subregion
 
在第I个位置放一个X,即可分为两个子游戏,I-3和n-I-2
 
#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<memory.h>
using namespace std;
int sg[2100];
int dfs(int n)
{
    if(n<0) return 0;//n<0
    if(sg[n]>=0) return sg[n];
    bool g[2001]={0};
    for(int i=1;i<=n;i++)
    {
        int t=dfs(i-3)^dfs(n-i-2);
        g[t]=1;
    }
    for(int i=0;;i++)
    if(g[i]==0) return sg[n]=i;
}
int main()
{
    memset(sg,-1,sizeof(sg));
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(dfs(n)) puts("1");
        else puts("2");
    }
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值