Doing Homework again

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12670    Accepted Submission(s): 7416


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 
题意:就是给了一些问题的期限deadline,并且给出了超过期限要扣多少分,求如何使扣的分最少
思路:换成求最大能获得多少分。按照deadline进行贪心,用优先队列进行保存最后所有留下来的值具体看代码
代码:
#include <iostream>
#include <map>
#include <vector>
#include <cstdio>
#include <queue>
#include <algorithm>
#include <cstring>

using namespace std;

const int MAX_N = 1005;
struct  point {
    int deadline;
    int val;
} p[MAX_N];

bool cmp(point a,point b) {
    return a.deadline < b.deadline;
}

int main() {
    int t;
    scanf("%d",&t);
    int n;
    while(t--) {
        scanf("%d",&n);
        int ans = 0;
        for(int i = 0; i < n; i++) {
            scanf("%d",&p[i].deadline);
        }
        for(int i = 0; i < n; i++) {
            scanf("%d",&p[i].val);
            ans += p[i].val;
        }
        p[n].deadline = 1002;
        p[n].val = 0;
        sort(p,p+n,cmp);
        priority_queue<int,vector<int>,greater<int> >que;
        for(int i = 1;i < p[0].deadline;i++){
            que.push(0);
        }
        que.push(p[0].val);
        for(int i = 1; i <= n; i++) {
            if(p[i].deadline == p[i-1].deadline && p[i].val > que.top()) {//当前的最后期限如果和前一个相等,并且比队列中最小的大,入队
                que.pop();
                que.push(p[i].val);
            }
            if(p[i].deadline != p[i-1].deadline) {//如果相邻的两个期限不等,并且有差值,那就说明有些天没任务,加入val = 0
                que.push(p[i].val);
                for(int k = p[i-1].deadline+1; k < p[i].deadline; k++) {
                    que.push(0);
                }
            }
        }
        int ans2 = 0;
        while(!que.empty()) {
            ans2 += que.top();
            que.pop();
        }
        printf("%d\n",ans-ans2);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值