最短路径___Heavy Transportation

Description

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

题目大意:有n个城市,m条道路,在每条道路上有一个承载量(道路双向),现在要求从1到n城市最大承载量,而最大承载量就是从城市1到城市n所有通路上的最大承载量


思路:Dijkstra 变形, dis[i] 表示城市1到城市i的最大承载量.  更新条件:

dis[next] = max( dis[next] , min( dis[now] , mpt[now][next] ) )

也可以用最大生成树来做.


Dijkstra:

#include <stdio.h>
#include <string.h>
#include <math.h>
#define INF 99999999

int mpt[1010][1010];
int dis[1010];
int visit[1010];
int Min1(int a,int b)
{
	if( a < b)return a;
	return b;
}
void Dijkstra(int x,int n)
{
    int i,j;
    for(i = 1; i <= n ; i ++)
			dis[i] = mpt[x][i];
    memset(visit,0,sizeof(visit));
    visit[x] = 1;
    for(i = 1; i < n ; i ++)
    {
        int Max = -1;
        int  Maxj = -1;
        for(j = 1; j <= n ; j ++)
        {
            if(visit[j]) continue;
            if( Max < dis[j])
            {
                Max = dis[j];
                Maxj = j;
            }
        }
        if(Maxj == -1)continue;
        visit[Maxj] = 1;
        for(j = 1; j <= n ; j ++)
        {
            if(dis[j] < Min1(dis[Maxj],mpt[Maxj][j])) dis[j] = Min1(dis[Maxj],mpt[Maxj][j]);
        }
    }
}
int main()
{
	int n,m,i,j,Case = 1,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(i = 1; i <= n ; i ++)
		{
			for(j = 1; j <= n ; j ++)
			{
				if( i == j ) mpt[i][j] = INF;
				else mpt[i][j] = -1;
			}
		}
		int u,v,len;
		for(i = 0 ; i < m ; i++)
		{
			scanf("%d %d %d",&u,&v,&len);
			if(mpt[u][v] < len)
			{
				mpt[u][v] = len;
				mpt[v][u] = len;
			}
		}
		Dijkstra(1,n);
		printf("Scenario #%d:\n%d\n\n",Case++,dis[n]);

	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值