POJ 1797 Heavy Transportation(题解+代码)

题目传送门:http://poj.org/problem?id=1797
题目:

Heavy Transportation

Description
Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

题意:计算从1到n的各种路径中,最大承载重量为多少,也就是说计算在1到n的某个路径中,最小边权值的大小
题解:可以直接计算最大生成树的最小边权值,或者用dijkstra求较大边权值也可
代码及注释如下:
解法1:

// 最大生成树prim(略快一点)
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 9999999
using namespace std;
int map[1005][1005],n,m;
int prim(int u) {
	int maxx = INF,lowc[1005],mst[1005];
	for(int i = 1;i <= n;i++) {//初始化
		lowc[i] = map[u][i];
		mst[i] = u;
	}
	mst[u] = -1;//标记起点
	for(int i = 1;i < n;i++) {
		int v = -1,minn = 0;//v为当前点,minn为权值
		for(int j = 1;j <= n;j++) {
			if(mst[j]!=-1&&minn<lowc[j]) {//找承载大的路
				minn = lowc[j];
				v = j;
			}
		}
		if(v!=-1) {
			maxx = min(minn,maxx);//取最小权值边
			mst[v] = -1;//标记当前点
			if(v==n) return maxx;//此时1可以到达n
			for(int j = 1;j <= n;j++) {
				if(mst[j] != -1 && lowc[j]<map[v][j]) {
					mst[j] = v;
					lowc[j] = map[v][j];//取较大权值
				}
			}
		}
	}
	return maxx;
}
int main() {
	int t;
	scanf("%d",&t);
	for(int cas = 1;cas <= t;cas++) {
		scanf("%d%d",&n,&m);//不能用cin(tle)
		int u,v,w;
		memset(map,0,sizeof(map));//初始化最小值
		while(m--) {
			scanf("%d%d%d",&u,&v,&w);//取较大值
			map[u][v] = map[v][u] = max(w,map[v][u]);
		}
		cout<<"Scenario #"<<cas<<':'<<endl;
		cout<<prim(1)<<endl<<endl;//多输出一个空行
	}
	return 0;
}

解法2:

//dijkstra
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 9999999
using namespace std;
int map[1005][1005],dis[1005],n,m,book[1005];
int dijkstra(int s) {
	for(int i = 1;i <= n;i++) {//初始化
		dis[i] = map[s][i];
	}
	memset(book,0,sizeof(book));
	book[s] = 1;
	for(int i = 1;i < n;i++) {
		int maxx = -1,u;
		for(int j = 1;j <= n;j++) {
			if(!book[j]&&dis[j]>maxx) {//寻找较大权值边
				maxx = dis[u = j];//更新maxx时也更新u的值
			}
		}
		if(maxx!=-1) {
			book[u] = 1;//标记已走过的点
			for(int j = 1;j <= n;j++) {
				if(!book[j]&&dis[j]< min(maxx,map[u][j])) {
					dis[j] = min(maxx,map[u][j]);
				}
				//dis[j]为直达的承载重量
				//maxx,map[u][j]为间接到达的各段路的承载重量
				/*
				如果直达的承载重量比间接到达的两个路的任一
				段路小的话,则需要更新dis数组
				*/
			}
		}
	}
	return dis[n];
}
int main() {
	int t;
	scanf("%d",&t);
	for(int cas = 1;cas <= t;cas++) {
		scanf("%d%d",&n,&m);
		int u,v,w;
		memset(map,0,sizeof(map));//初始化为0
		while(m--) {
			scanf("%d%d%d",&u,&v,&w);//取较大值
			map[u][v] = map[v][u] = max(w,map[v][u]);
		}
		cout<<"Scenario #"<<cas<<':'<<endl;
		cout<<dijkstra(1)<<endl<<endl;//多输出一个空行
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值