Robberies(反向思考+01背包)

Robberies
题目链接:https://vjudge.net/contest/429740#problem/D

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints

0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6
这道题本质上也是01背包问题,如果按我最开始的思维把小数乘以1 e e e 6的话,过不了,会超时,其实想想小数多少位也不知道,就算不超时也危,后面学习了大佬的做法,我发现这里要转化一下思维,以钱当背包容量,适当做一点修改。还要注意一下清零的问题了(有些题会有影响)题解如下:

题解

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#define int long long
using namespace std;
double dp[10010];
double weight[10010];
int value[10010];
signed main()
{
	int t;
	cin>>t;
	while(t--)
	{
		memset(dp,0,sizeof(dp));
		memset(weight,0,sizeof(weight));
		memset(value,0,sizeof(value));
		double a,b;
		int n;
		cin>>a>>n;
		a=1-a;
		
		int sum=0;
		for(int i=1;i<=n;i++)
		{
			cin>>value[i]>>weight[i];
			weight[i]=1-weight[i];
			sum+=value[i];
		}
		dp[0]=1.0;
		for(int i=1;i<=n;i++)
		{
			for(int j=sum;j>=value[i];j--)
			{
				dp[j]=max(dp[j],dp[j-value[i]]*weight[i]);
			}
		}
		int ans=0;
		for(int i=sum;i>=0;i--)
		{
			if(dp[i]>=a)
			{
				ans=i;
				break;
			}
		 } 
		cout<<ans<<endl;	
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值